
SurveyTag User Guide 

Microclimate Logger MC-01 with 
0.075mm K-type thermocouple 

Guide version 08  17th Jan 2023 

www.surveytag.co.uk 

https://surveytag.co.uk/


Warning – to keep water out of the unit: 
• Make sure the cable gland is tightly closed on the 

thermocouple tube. 

• Ensure the end cap with o-ring is done up firmly by hand 
so it seals well (but not so tight that the o-ring is pushed 
out). 

• Use the silica gel sachet provided inside the unit to 
absorb any moisture from the air entering when the unit 
is opened.  

• Check the screen window has not been damaged or 
pierced by sharp items. 

Warning – fragile thermocouple 

• By design, the thermocouple is extremely delicate and 
while the ultrafine wires are flexible, care needs to be 
taken in handling it – always fit the yellow protective 
tube unless it is actually logging. 

• Think about how the unit will be protected in-situ from 
insects and animals and the impact of weather on it, 
including snow, ice and hail.  

• If it does get broken, please get in touch as we can 
replace the thermocouple or supply one for you to fit. 



Fine wire 0.075mm 
thermocouple junction 
at end (lacquered) 

Cable gland 

Screw cap with o-ring to 
access USB & battery 

Function button 

Yellow protective transit 
cover for thermocouple. 
Remove before use & retain. 

Integral plastic tube to 
support thermocouple 

To use the logger, you will need: 

• 1 x AA (LR6) alkaline battery (please get in touch to 
discuss using rechargeable or lithium). 

• A USB-C cable to connect it to your computer. 

• A computer with a USB port. 

• A free serial terminal programme such as TeraTerm or 
CoolTerm installed on your computer. 



The SurveyTag Display 

Sleep mode – press the button to see / check the current temperature. Connect to 
USB to set-up time, date & logging mode or to send unit to sleep. 

Set mode – shows when first powered up. Connect to USB to set-up time, date and 
logging parameters. 

Ready mode – Waiting for a button press to start logging using the parameters set 
via USB. Note the time and date have to be set to enter this mode. 

USB mode – shows the USB cable is plugged into the unit. 

Temperature display – Shows the temperature in degrees C. This may be a single 
measurement or the average of a number of samples, depending on the 
configuration. 

Log mode – shows the unit is logging. Each time it wakes and stores a reading, or 
average from a burst of readings, it will show the temperature on the display 
momentarily. If you wish to know / test the temperature reading during logging, 
press the button and it will display a reading, but without storing it or disrupting the 
logging. 

The battery symbol shows battery state (voltage) in three segments. The symbol 
shown with 3 black segments is a full battery. Change the battery at one segment. 
No segment shown indicates the battery is below a useable voltage. Note if using a 
rechargeable (NiMh) battery, it will only display a maximum of two segments. 

Battery flat (below approx 0.95 volts), logging was stopped to protect the data. 
Connect to USB power to clear the screen and replace the battery. 



Connecting the SurveyTag unit to a computer (Windows 10) 

Unscrew the cap from the unit and insert the USB-C connector 
using a USB-C cable. Connect the other end of the cable to a USB 
port on your computer. The logger should show ‘USB’ on the 
display. IF THE LOGGER SCREEN DOES NOT SHOW ANYTHING, 
DISCONNECT & ENSURE BATTERY POLARITY IS CORRECT BEFORE 
RECONNECTING. 

Download and install a serial terminal program to your PC such as the free open source 
Tera Term (Windows) terminal emulator from 
https://osdn.net/projects/ttssh2/releases/ 

The .exe file tends to be the easiest. CoolTerm is also free and works on Mac or PC from 
Roger Meier's Freeware (the-meiers.org)  

For Windows users: Connect the SurveyTag to 
your computer first and then run Tera Term, 
otherwise it will not list the right serial (com) 
port.  

 

Select ‘Serial’ and then select the com port 
your device is connected to.  Here it happens 
to be COM11. If you cannot see it listed, closed 
Tera Term, unplug and then plug in the 
SurveyTag unit and re-run Tera Term. Now click 
‘OK’. If you have used TeraTerm before, it may 
open with the previous connection, so go 
File>Disconnect and then File> New 
Connection and it will show the com port. 
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You should now see the black terminal window. From the menu 
select Setup > Serial port and set the speed (baud rate) to 
115200, data to 8 bit, parity to none and stop bit to 1 as shown. 
This step is not essential, since the SurveyTag unit auto detects 
the baud rate. TeraTerm should remember the port speeds etc. 

 

To make the terminal window easier to see, go to Setup > Font > 
Font and choose ‘Terminal Greek 737’ in size 12. Also maximise 
the terminal window to full screen. 

 

You can save your settings for next time by going to Setup > Save 
Setup. 

 

IMPORTANT NOTE: If you change the font settings etc. of the 
terminal window, it will clear the screen (an example of why using 
the log file is useful). 

 

Next set-up screen logging, so what you see in the terminal 
windows is saved to a text file on your computer. In Tera Term, go 
to File > Log and choose where to save the log file. Logging is very 
useful to prevent accidental loss of data. YOU HAVE TO SET THIS 
UP EACH TIME YOU OPEN TERA TERM. It is also the best way of 
capturing the data from the SurveyTag unit and storing it as a text 
file. 

 

IMPORTANT NOTE: As you type in the terminal window, it sends 
each keypress to the SurveyTag unit, so there is no backspace / 
delete. Also note the num keypad part of keyboard should be 
avoided as it is not supported and you may find errors in setting 
date and time etc. If you use ‘/’ and other keys on it. 

 

 

 



Press ‘Enter’ on your keyboard and SurveyTag should display the 
configuration menu. This shows it is correctly connected. If you 
cannot see the whole menu, simply resize the terminal window. 
Press Enter again to display it.  

 

The example here shows: 
Hardware version: (hw) v05 

Firmware version: (fw) v1.31 

Unique logger name: SurveyTag-*** 

Sampling period is 600 seconds = 10 minutes. 

Burst length is 1.2 seconds 

Samples is set to 16 

The battery voltage is 1.3v (1269mV) 

 

 

 

 

 

 

Set Date & Time 
Press B to set the date and time. You are required to type in the ‘/’ and ‘:’ Do not use the num keypad on your keyboard as it 
will not recognise the symbol keys.. 
 
 
 
 
 

*** 



How the logger works 
The voltage generated by the thermocouple junction (the temperature sensor) is measured by a dedicated 
thermocouple chip. This chip has high speed on-board averaging and can be set to take 1, 2, 4, 8 or 16 
readings (the Sample Average Count) and then pass the resulting single averaged reading to the logger’s 
software that runs on the main microcontroller.  

 

The logger sleeps most of the time to save power. It wakes up every Sample Period seconds and stays 
awake for Burst Length seconds, repeatedly requesting the averaged readings from the thermocouple chip. 
The longer it is awake for, the more of the averaged readings it takes. Finally before going back to sleep, the 
logger averages all the readings together into a single value and stores it in the flash memory chip along 
with the date and time. 

 

Battery life is dependent on how long the logger is awake for, effectively set by Burst Length. Use our 
Battery Life Estimator tool to work out the number of samples you need and approximate battery life. 

 

 

 

 

https://surveytag.co.uk/battery/


 

 

 

 



Definitions  
Sample Period (s): How often the logger wakes up to take a set of readings. You may want this to be hourly or sometimes every 
five or ten minutes. You are making a trade-off between battery life and the amount of data you collect. Generally set to 30 mins 
or an hour. Recommend a minimum of 10 seconds when sample averaging is used. [Press C to set the sample period]. 

  

Burst Length (mS): 1000mS = 1 second. How long the logger wakes up for to take readings. The longer the burst length, the more 
times it requests readings from the thermocouple chip. Taking readings is power hungry; the longer the burst length, the more 
energy is used from the battery. You can set it to 0mS and it will still request a reading from the thermocouple chip once. See the 
Battery Life Estimator tool on our website for more details.  [Press D to set the burst length]. 

 

Getting the Sample Period and Burst Length correct for your application is vital as it varies battery life from 2 days to more 
than a year. 

  

Sample Average Count: The logger has a dedicated thermocouple measurement chip that passes readings back to the logger’s 
software. This chip has high speed on-chip averaging to return a single averaged reading from 1/2/4/8/16 samples. To set the on-
chip Sample Average Count [Press G]. 
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Set Log Start mode (often use button start) 
Press E to set. Button-press mode will show                     on the display, and not log until the button is pressed. 
 
Once logging has started,                  is shown. Each time the units wakes to take a reading, it will briefly display the reading. 
 
 
 
Thermocouple type (default is K type) (NOT NORMALLY REQUIRED) 
Press F to set the thermocouple type. Supported types are B, E, J, K, N, R, S or T. The default is K-type. 
 
 
Set On-chip Sample Average Count 
Press G to set the on-chip averaging. This is explained under ‘Set Burst Length’ above. 
 
 
Write Out Readings 
Press K to write out a CSV-compatible data page of the stored readings. Once they have been written out, the terminal 
content can be saved or copied and pasted as required. 
 
Delete Readings 
Press L to delete stored readings in the device. The device configuration is not cleared. 
 
 
Sleep Mode (usually use this when you are finished for a logger for a few days or weeks). 
Press N to put the SurveyTag into low-power sleep mode. This ends any logging taking place and shuts down the processor. It 
is useful if the SurveyTag needs to be stored with the battery in. The SurveyTag can be woken up again by plugging in the USB 
port. When in sleep you can still press the button to take a single reading displayed on the screen (but not stored). If the unit 
is going to be stored for many months, then it is best to remove the battery, as with any device. 
 
 



Set Logger Name (already set by default and also shown on the enclosure label) (NOT NORMALLY REQUIRED) 
Press H to set the name of the logger. The default is SurveyTag-NNNN or just NNNN where NNNN is a unique 4-digit 
alphanumeric serial number. 
 
Set Display Contrast 
Press I to set the display contrast. This is currently not implemented. 
 
 
Set Calibration Offset 
Press J to set a calibration offset. This is entered in millidegrees based on calibration of the logger. For example, if the logger 
reads 0.3 degrees too high during calibration, then set this value to -300. Similarly, if the logger reads 0.1 degrees too low, set 
this value to 100. If you accidently delete the value and are not able to calibrate against a known temperature, get in touch, 
we should have its original calibration value recorded. To calibrate, place the thermocouple junction in water with a reference 
thermometer (allow it to stabilise as it is unlikely to have as fast a response as the SurveyTag unit) and calculate the 
difference. 
 
Format Flash (NOT NORMALLY REQUIRED) 
Press M to format the flash memory. A confirmation is requested from the user. This erases all of the on-board memory, 
effectively restoring the SurveyTag to factory settings. This can be useful if there is a problem with memory corruption. Day to 
day you would use ‘Delete Readings’ to delete logging data. 
 
 
 
 
 



Display battery voltage 
Press O to take an updated reading of the battery voltage. Useful to check if a battery is OK. If you are going to be deploying 
the unit to log over many weeks or months, always use a fresh battery (a new alkaline AA battery should have a voltage of 
around 1.6v (1600mV). 
 
 
Write out raw flash content (NOT NORMALLY REQUIRED) 
Press P to write out all the raw data on the memory chip – this is only used for advanced data recovery and is should not be 
needed. 
 
 



Downloading results 

In the terminal window, check you have the log file enabled (File > Log), then enter ‘K’ and press Enter. The results should 
appear in the terminal window. There is an option to delete the results, choose No (you can delete them later).  

 

You can now copy and paste all the results from the terminal window, or better, if you are using a log file, then simply go to 
File > View Log. Save this log file into another text file or copy the part you want and paste or import into Excel. In Excel click 
on cell A1 and paste. It should import correctly in the columns from the text file. If not, then use Excel’s Data > Text to 
columns function. 

 

TC_Reading is the column showing the temperature readings. CJ_Readings are the internal logger cold junction 
temperatures, vBatt shows the voltage of the AA battery in millivolts (around 1600mV for a new one). Samples show how 
many rounds of on-chip samples were taken during the burst. If on-chip samples is set to 16, then ‘3’ indicates it took the 
average of 16 samples  three times in the burst period and stored one averaged result for 3x16 = 48 samples. 

 

 

 

 

 

 

 

Once you have your data safely saved  in Excel, use ‘L’ in Tera Term to delete the readings from the logger and ‘N’ to put the 
logger into sleep mode to save power. 

 

 

 

 



Changing the Battery 

1. IMPORTANT: Loosen the cable gland to allow the thermocouple tube to move freely, 

2. Unscrew the access cap. 

3. Gently withdraw the circuit board ensuring the thermocouple tube can freely pull through the cable gland. 
Access the battery and replace with a new 1.5v AA battery.  CHECK POLARITY. It may be useful to label the 
battery with the install date. Carefully slide the circuit board back on its rails into the enclosure while gently 
pulling the thermocouples tube through the cable gland. 

4. Re-tighten the cable gland firmly on the thermocouple tube to ensure a watertight seal.  

5. Connect USB to a computer to reset the date and time and configuration. 

6. Refit the access cap and tighten firmly by hand. 

 

 

 

 

 

 

1 2 3 4 



Technical Specification 
Storage Capacity 

The size of the on-board memory is 32 megabytes, with 16 megabytes accessible currently (a future firmware update will  be 
available to access the full 32 megabytes). The 16 megabytes is enough for approx. 500,000 temperature readings. 

 

Output Data Format 

The output data written to the terminal is in CSV format and can be pasted into a text editor and saved as a .csv to make it 
readable in spreadsheet programs such as Excel. Make sure the header line is also saved to get column headings. 

 

vBatt (shown in logged data) 

Battery voltage in millivolts. 1000 = 1v. Typically a new Alkaline battery is around 1600mV. The unit will  operate down to 950mV. 
At this point the battery is  considered exhausted and the unit will shut off to protect the data. The screen will display ‘bAt’ until 
you connect the USB cable. See the Battery Life Estimator tool on our website for more details.  

 

Samples (shown in logged data) 

The number of readings that went into the sample. 

 

Fault Code (shown in logged data) 

A number representing a bitfield of fault codes, as follows: (individual values are summed to create the fault code number) 

1 = Thermocouple open circuit (note: currently this fault is reported as Thermocouple out of range, see below) 

2 = Over or Under voltage on thermocouple input. This will happen if external voltage is applied to the thermocouple 

6 = Thermocouple temperature out of range (this is reported when the thermocouple is not connected) 

7 = Cold junction temperature out of range (-55°C to +125°C for types E, J, K, N, and T; -50°C to +125°C for types R and S; 0 to 
125°C for type B). 

 

 

 

https://surveytag.co.uk/battery/


Battery Type & Life 

1 x 1.5v AA (LR6) alkaline or AA lithium battery. Rechargeable NiMh cells will also work, but will initially show only two segments 
in the battery icon. Battery Life: Variable depending on logging frequency, but up to 1 year. The longer the burst length, the more 
battery power is consumed. By running a burst of 1000mS and a sample period of 5 seconds, you can use an AA battery in only a 
day. Get in touch if you would like to discuss the details. The intended use of the unit  was to log a few times an hour over a few 
months. See the Battery Life Estimator tool on our website for more details.  

 

Weight: approx. 100 grams including AA battery, cap , TC tube and yellow TC cover. Dimensions (approx) Logger 140mm long plus 
170mm for the thermocouple tube and junction (total length 310mm).  Approx 45mm diameter including feet. 

 

Thermocouple specification 

The unit is currently fitted with a K type 0.075mm thermocouple with an exposed junction. The thermocouples are supplied by 
Labfacility. We apply a small amount of lacquer to the exposed junction to reduce corrosion. 

 

Country of Origin: UK  Manufactured and assembled in Bristol  & Cornwall.  

 

Repair & Disposal 

Please return unwanted & faulty units to us at the address shown on the contact page, stating if you 

would like a repair or no longer require the unit. We are able to repair and recondition most units or 

reuse the components themselves.  

 

Hardware versions  

June 2021 – Prototype version 01 (with microSD card) 

Oct 2021 – Prototype version 02 (with internal flash) 

Nov 2021 – added integral thermocouple support tube. 

March 2022 – Prototype version 04 with full USB-C support and injection moulded enclosure. 

May 2022 – Production version  05. (Sept 2022 upgraded o-rings). 

Current firmware version: v1.37 Sept 2022 
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Support & Contact details 

 

www.surveytag.co.uk 

 

Concept Shed Ltd 

1 The Old Lemonade Factory 

Falmouth TR11 3EX 

United Kingdom 

+44 1326 316536 
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